「有効期間内の日付を選択してください」というエラーが表示される場合
申請画面の選択肢に該当の休日休暇名が表示されない場合
①申請に必要な残数が付与されていない
②ブラインド機能が設定されている
有効期間内の日付を選択してくださいというエラーが表示される場合
休日休暇の日数が付与されているのに[有効期間内の日付を選択してください]と
エラーメッセージが表示されて、申請できない場合は下記内容をご確認ください。
原因
休暇取得予定日が特別休暇の有効期間外(申請期限外)である可能性があります。
操作日が有効期間内であっても休暇取得予定日が期限外の場合は、
付与日数があってもエラーが発生して、申請を提出することができません。
例)誕生日休暇を休日休暇申請する
付与日数:1
申請期限:2020/6/1~6/31
申請日(操作日):2020/6/19
休暇取得予定日:2020/7/8
対処方法
【再度申請を行う場合】
従業員の方は、有効期間内の日付を選択して再度申請を行ってください。
申請方法はこちらです。
【該当の休暇の申請期限を変更する場合】
管理者の方は、別の申請期限で再度従業員に付与する必要があります。
付与の方法はこちらです。
申請画面の選択肢に該当の休日休暇名が表示されない場合
休日休暇申請画面の[休日休暇名]から該当の特別休暇名が選択肢に表示されない場合は、
下記内容をご確認ください。
①申請に必要な残数が付与されていない可能性があります。
申請に必要な有効な残数が付与されていない場合、下記3点をご確認ください。
3点のいずれかの内容が、付与されていない原因に該当する可能性があります。
原因1:申請期限切れ
下記例のように、2020/7/1時点で振休の申請期限が切れて残日数が0になってしまった場合、
申請画面の選択肢に表示されなくなります。
例)振休を申請する
付与日数:1
申請期限:2020/6/1~6/31
申請日(操作日):2020/7/1
対処方法
管理者画面にて、対象日と申請日(操作日)を含む有効期限の休暇を新規付与してください。
年次有給休暇/振休/代休を付与する場合はこちら
特別休暇を付与する場合はこちら
※休暇の残日数が0になって消滅した経緯を確認する場合はこちら
原因2:自動付与が行われない特別休暇が該当従業員へ付与されていない
特別休暇マスタにて自動付与設定を「設定しない」と設定されている特別休暇が、
該当従業員へ残数が付与されていない可能性があります。
該当メニュー:休日休暇設定>特別休暇設定>特別休暇マスタ
特別休暇マスタを作成する方法はこちら
対処方法
特別休暇一覧にて、該当の特別休暇を新規付与してください。
新規付与する場合は、下記例のように申請日と取得日の両方を含む期間を設定してください。
例)申請日2021/1/1、特別休暇取得日2021/1/15の場合
→有効期間:2021/1/1~2021/1/15を含む期間
新規付与の方法はこちら
原因3:自動付与の特別休暇が条件を満たしていないため付与されていない
特別休暇マスタにて、自動付与設定を「設定する」と設定されているが、
付与条件を満たしていないため、該当従業員へ残数が付与されていない可能性があります。
対処方法
例)付与日が「登録日」または「入社日」の設定内容をご確認ください。
付与条件を満たしていない原因の多くは、
「登録日」と「入社日」の設定が影響している可能性があります。
登録日:従業員が新規で登録され、打刻グループに紐づいた時点で付与されます
入社日:入社日の○年○ヶ月後に付与されます
既存の従業員へ付与したい場合はこちらの設定方法をご確認ください。
②就業規則設定のブラインド機能が設定されている可能性があります。
就業規則設定>編集>その他>ブラインド機能で休日休暇にチェックが入っていると、
従業員画面上で該当の休日休暇が非表示となり、申請ができなくなります。
例)就業規則名:東京本社
ブラインド機能で「特別休暇」にチェックを入れた場合
「東京本社」に紐づいている従業員の申請画面で「特別休暇」が非表示となり申請もできなくなります
対処方法
ブラインド機能を「設定しない」に設定してください。
または、申請が必要な休日休暇のチェックを外してください。
ブラインド機能の設定方法はこちら